Firefox 1.5

I know I'm a little late. I actually debated for a long time before upgrading because many of th...

I know I’m a little late. I actually debated for a long time before upgrading because many of the extensions that I use are not compatible with Firefox 1.5

Sharing is caring:

Talk to me, Goose.

This site uses Akismet to reduce spam. Learn how your comment data is processed.